Difference between revisions of "WineHQ Repository nl"

From WineHQ Wiki
Jump to: navigation, search
(Created page with "__NOTOC__ {{DISPLAYTITLE:{{{1}}} WineHQ Repository}} == WineHQ Packages == {| |style="width:50px;"|[[File:Icon-distro-{{{2}}}.png|40px|link={{{1|}}}]] |Hoewel {{{1}}} zijn ei...")
 
(→‎Missende afhankelijkheden: Opmaak, KDE Neon stuk toegevoegd)
 
(5 intermediate revisions by the same user not shown)
Line 14: Line 14:
 
  sudo dpkg --add-architecture i386  
 
  sudo dpkg --add-architecture i386  
  
 +
== WineHQ archief toevoegen ==
 
Voeg de verificatiesleutel van de WineHQ server toe aan het systeem:
 
Voeg de verificatiesleutel van de WineHQ server toe aan het systeem:
 
  sudo mkdir -pm755 /etc/apt/keyrings
 
  sudo mkdir -pm755 /etc/apt/keyrings
 
  sudo wget -O /etc/apt/keyrings/winehq-archive.key https://dl.winehq.org/wine-builds/winehq.key
 
  sudo wget -O /etc/apt/keyrings/winehq-archive.key https://dl.winehq.org/wine-builds/winehq.key
  
== WineHQ archief toevoegen ==
 
 
Kies de gebruikte {{{1}}} versie en download het WineHQ sources bestand:
 
Kies de gebruikte {{{1}}} versie en download het WineHQ sources bestand:
  
Line 48: Line 48:
 
== Help ==
 
== Help ==
 
Het kan gebeuren dat er problemen zijn bij het installeren van Wine. Als het probleem niet hier staat, doorzoek dan het [https://forums.winehq.org/WineHQ forum]. Mocht ook daar geen antwoord te vinden zijn, stel dan daar je vraag.  
 
Het kan gebeuren dat er problemen zijn bij het installeren van Wine. Als het probleem niet hier staat, doorzoek dan het [https://forums.winehq.org/WineHQ forum]. Mocht ook daar geen antwoord te vinden zijn, stel dan daar je vraag.  
 
  
 
=== Missende afhankelijkheden ===
 
=== Missende afhankelijkheden ===
* De WineHQ pakketten worden gemaakt en getest voor een schone {{{1}}} installatie.
+
Lees de [[FAQ_nl#Ik_krijg_een_foutmelding_dat_Wine_niet_ge.C3.AFnstalleerd_kan_worden.2C_omdat_sommige_afhankelijkheden_niet_opgelost_kunnen_worden.|FAQ]] om afhankelijkheidsproblemen op te lossen. De meeste voorkomende problemen zijn:
 +
==== Pakketbronnen van derden ====
 +
De WineHQ pakketten worden gemaakt en getest voor een schone {{{1}}} installatie.
 
Het gebruik van PPA's of pakketbronnen van derden kunnen de installatie van Wine verhinderen.
 
Het gebruik van PPA's of pakketbronnen van derden kunnen de installatie van Wine verhinderen.
 
Vaak is het probleem dat deze repositories niet multiarch zijn. De benodigde 32 en 64-bit pakketten ontbreken of kunnen niet samen geïnstalleerd worden.
 
Vaak is het probleem dat deze repositories niet multiarch zijn. De benodigde 32 en 64-bit pakketten ontbreken of kunnen niet samen geïnstalleerd worden.
De ''deb.sury.org'' pakketbron is berucht voor het veroorzaken van problemen.
+
De ''deb.sury.org'' pakketbron is berucht voor het veroorzaken van problemen. De oplossing is om van de problematische afhankelijkheden de officiële {{{1}}} versie te installeren.
 +
 
 +
==== KDE Neon ====
 +
Ubuntu 22.04 KDE Neon gebruikers melden problemen met de ''libpoppler-glib8'' afhankelijkheid. De oplossing is om van dit pakket de Ubuntu versie te installeren. <code>sudo apt install libpoppler-glib8:{i386,amd64}=22.02.0-2ubuntu0.1</code>
  
* Een andere oorzaak kan het gebruik van backports zijn.
+
==== Backports ====
 +
Een andere oorzaak kan het gebruik van backports zijn.
 
Een nieuwe versie van een 64-bit bibliotheek is al geïnstalleerd, maar de 32-bit versie nog niet. De pakketten uit de backports repository krijgen een lage prioriteit mee waardoor ze niet automatisch geïnstalleerd worden. Installeer handmatig het ontbrekende 32-bit pakket uit backports.
 
Een nieuwe versie van een 64-bit bibliotheek is al geïnstalleerd, maar de 32-bit versie nog niet. De pakketten uit de backports repository krijgen een lage prioriteit mee waardoor ze niet automatisch geïnstalleerd worden. Installeer handmatig het ontbrekende 32-bit pakket uit backports.
  
* Oudere versies van Wine (tot versie 6.21) hebben Faudio als afhankelijkheid.
+
==== Faudio ====
 +
Oudere versies van Wine (tot versie 6.21) hebben Faudio als afhankelijkheid.
 
Deze pakketten ontbreken voor Ubuntu 18.04. Download de pakketten van de [https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04/ Open Build Service].
 
Deze pakketten ontbreken voor Ubuntu 18.04. Download de pakketten van de [https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04/ Open Build Service].
 
Voor Debian 10, staan deze pakketten in backports.
 
Voor Debian 10, staan deze pakketten in backports.
 
* Lees ook de [[FAQ_nl#Ik_krijg_een_foutmelding_dat_Wine_niet_ge.C3.AFnstalleerd_kan_worden.2C_omdat_sommige_afhankelijkheden_niet_opgelost_kunnen_worden.|FAQ]] om afhankelijkheidsproblemen op te lossen.
 
  
 
=== Problemen met de Winehq key  ===
 
=== Problemen met de Winehq key  ===
Line 74: Line 78:
 
* '''Op 19 december 2018 is de verificatiesleutel van de WineHQ server gewijzigd'''
 
* '''Op 19 december 2018 is de verificatiesleutel van de WineHQ server gewijzigd'''
 
Mocht de sleutel voor die tijd zijn gebruikt, dan moet deze opnieuw worden toegevoegd. Gebruik <code>sudo apt update</code> om de veranderingen door te voeren.
 
Mocht de sleutel voor die tijd zijn gebruikt, dan moet deze opnieuw worden toegevoegd. Gebruik <code>sudo apt update</code> om de veranderingen door te voeren.
 
  
 
* '''Apt-key is verouderd'''
 
* '''Apt-key is verouderd'''
Line 80: Line 83:
 
Mocht hierover een melding komen, verwijder de sleutel met:
 
Mocht hierover een melding komen, verwijder de sleutel met:
 
<code>sudo apt-key del "D43F 6401 4536 9C51 D786 DDEA 76F1 A20F F987 672F"</code> Verwijder hierna ook de regel van het WineHQ-archief uit ''/etc/apt/sources.list(.d/)''.
 
<code>sudo apt-key del "D43F 6401 4536 9C51 D786 DDEA 76F1 A20F F987 672F"</code> Verwijder hierna ook de regel van het WineHQ-archief uit ''/etc/apt/sources.list(.d/)''.
 
=== Ubuntu 22.04 en Wine stable ===
 
Er zijn nog geen Wine-stable-pakketten voor Ubuntu 22.04. Ubuntu Jammy Jellyfish bestond namelijk nog niet toen Wine 7.0 werd uitgebracht. De Wine-stable-pakketten worden gemaakt als versie 7.0.1 uitkomt.
 
  
 
=== Mirror sync in progress? ===
 
=== Mirror sync in progress? ===
Line 91: Line 91:
 
Wacht een paar uur en probeer het nog een keer. Als het probleem meer dan een dag duurt, maak dan een foutrapport aan.
 
Wacht een paar uur en probeer het nog een keer. Als het probleem meer dan een dag duurt, maak dan een foutrapport aan.
  
 +
=== Mijn {{{1}}} versie staat er niet tussen ===
 +
Wanneer een versie van {{{1}}} niet meer ondersteund wordt, worden er geen nieuwe Wine pakketten meer voor gemaakt. Je kan op de [https://dl.winehq.org/wine-builds/ WineHQ server] kijken of er oudere pakketten beschikbaar zijn. Het toevoegen van de WineHQ server is niet nodig. Er worden namelijk geen nieuwe versies meer gemaakt. Het downloaden en installeren van [[#Notities | de vier WineHQ]] deb-pakketten is voldoende.
 +
 +
Let op: deze pakketten worden niet meer bijgewerkt en worden niet meer ondersteund.
  
 
== Notities ==
 
== Notities ==
Line 99: Line 103:
 
* Er zijn geen pakketten voor ''wine-mono'' en ''wine-gecko''. Deze worden automatisch gedownload en geïnstalleerd als Wine voor de eerste keer wordt gestart of als er een nieuwe wineprefix wordt gemaakt. Als dit niet lukt, lees dan de wiki pagina's van [[Gecko]] of [[Mono]].
 
* Er zijn geen pakketten voor ''wine-mono'' en ''wine-gecko''. Deze worden automatisch gedownload en geïnstalleerd als Wine voor de eerste keer wordt gestart of als er een nieuwe wineprefix wordt gemaakt. Als dit niet lukt, lees dan de wiki pagina's van [[Gecko]] of [[Mono]].
  
* Vanaf Wine 5.7 kunnen de WineHQ pakketten ingesteld worden met debconf om gebruik te maken van CAP_NET_RAW. Veel programma's hebben dit niet nodig en is om veiligheidsredenen uitgeschakeld. Als dit wel nodig is (omdat bijvoorbeeld het programma het ping commando nodig heeft) voer dan de volgende opdracht uit en beantwoord de drie vragen met "ja":
+
* Vanaf Wine 5.7 kunnen de WineHQ pakketten ingesteld worden met debconf om gebruik te maken van CAP_NET_RAW. Veel programma's hebben dit niet nodig en is om veiligheidsredenen uitgeschakeld. Als dit wel nodig is (omdat bijvoorbeeld het programma het ping commando nodig heeft) voer dan de volgende opdracht uit en beantwoord de drie vragen met "ja": <code>dpkg-reconfigure wine-<soort>-amd64 wine-<soort> wine-<soort>-i386</code>
<code>dpkg-reconfigure wine-<soort>-amd64 wine-<soort> wine-<soort>-i386</code>
 
  
 
* Er wordt geen Binfmt_misc registratie uitgevoerd. Lees de documentatie van {{{1}}} om dit handmatig te doen (<code>man update-binfmts</code>).
 
* Er wordt geen Binfmt_misc registratie uitgevoerd. Lees de documentatie van {{{1}}} om dit handmatig te doen (<code>man update-binfmts</code>).
Line 128: Line 131:
 
:: <code>sudo apt install winehq-staging=7.12~bookworm-1 wine-staging=7.12~bookworm-1 wine-staging-amd64=7.12~bookworm-1 wine-staging-i386=7.12~bookworm-1</code>
 
:: <code>sudo apt install winehq-staging=7.12~bookworm-1 wine-staging=7.12~bookworm-1 wine-staging-amd64=7.12~bookworm-1 wine-staging-i386=7.12~bookworm-1</code>
  
== Installing without Internet ==
+
== Een installatie zonder internet ==
 
Om Wine op een {{{1}}} computer zonder internetverbinding te kunnen installeren is een tweede {{{1}}} computer (of VM) met een internetverbinding nodig. Deze kan de benodigde deb-pakketten downloaden.
 
Om Wine op een {{{1}}} computer zonder internetverbinding te kunnen installeren is een tweede {{{1}}} computer (of VM) met een internetverbinding nodig. Deze kan de benodigde deb-pakketten downloaden.
  

Latest revision as of 06:57, 10 November 2022


WineHQ Packages

[[File:Icon-distro-{{{2}}}.png|40px|link=]] Hoewel {{{1}}} zijn eigen Wine pakketten heeft, zijn deze vaak verouderd.

Om de installatie van de nieuwste Wine versie zo makkelijk mogelijk te maken heeft WineHQ zijn eigen {{{1}}} repository. Als een nieuwere versie problemen geeft, dan kan er ook oudere versie naar keuze geïnstalleerd worden.

Voorbereiding

Op 64-bit systemen moeten ook 32-bit pakketten geïnstalleerd kunnen worden. Als dit nog niet gedaan is, schakel dit in met:

sudo dpkg --add-architecture i386 

WineHQ archief toevoegen

Voeg de verificatiesleutel van de WineHQ server toe aan het systeem:

sudo mkdir -pm755 /etc/apt/keyrings
sudo wget -O /etc/apt/keyrings/winehq-archive.key https://dl.winehq.org/wine-builds/winehq.key

Kies de gebruikte {{{1}}} versie en download het WineHQ sources bestand:

{{:{{{1}}}_versions}}


Werk de pakketbronnen bij met:

sudo apt update

Wine installeren

Installeer één van de volgende pakketten:

Stable versie
sudo apt install --install-recommends winehq-stable
Development versie
sudo apt install --install-recommends winehq-devel
Staging versie
sudo apt install --install-recommends winehq-staging

Op de WineHQ Wiki staan de verschillen tussen de verschillende Wine soorten

Help

Het kan gebeuren dat er problemen zijn bij het installeren van Wine. Als het probleem niet hier staat, doorzoek dan het forum. Mocht ook daar geen antwoord te vinden zijn, stel dan daar je vraag.

Missende afhankelijkheden

Lees de FAQ om afhankelijkheidsproblemen op te lossen. De meeste voorkomende problemen zijn:

Pakketbronnen van derden

De WineHQ pakketten worden gemaakt en getest voor een schone {{{1}}} installatie. Het gebruik van PPA's of pakketbronnen van derden kunnen de installatie van Wine verhinderen. Vaak is het probleem dat deze repositories niet multiarch zijn. De benodigde 32 en 64-bit pakketten ontbreken of kunnen niet samen geïnstalleerd worden. De deb.sury.org pakketbron is berucht voor het veroorzaken van problemen. De oplossing is om van de problematische afhankelijkheden de officiële {{{1}}} versie te installeren.

KDE Neon

Ubuntu 22.04 KDE Neon gebruikers melden problemen met de libpoppler-glib8 afhankelijkheid. De oplossing is om van dit pakket de Ubuntu versie te installeren. sudo apt install libpoppler-glib8:{i386,amd64}=22.02.0-2ubuntu0.1

Backports

Een andere oorzaak kan het gebruik van backports zijn. Een nieuwe versie van een 64-bit bibliotheek is al geïnstalleerd, maar de 32-bit versie nog niet. De pakketten uit de backports repository krijgen een lage prioriteit mee waardoor ze niet automatisch geïnstalleerd worden. Installeer handmatig het ontbrekende 32-bit pakket uit backports.

Faudio

Oudere versies van Wine (tot versie 6.21) hebben Faudio als afhankelijkheid. Deze pakketten ontbreken voor Ubuntu 18.04. Download de pakketten van de Open Build Service. Voor Debian 10, staan deze pakketten in backports.

Problemen met de Winehq key

  • W: GPG error: https://dl.winehq.org/ ... NO_PUBKEY 76F1A20FF987672F

Op dit moment worden de verschillende servers van Wine gesynchroniseerd. Hierdoor kan het voorkomen dat een oud .sources-bestand wordt binnengehaald. De oplossing is om het winehq-<distro>.sources bestand aan te passen en /usr/share/keyrings/ te vervangen door /etc/apt/keyrings/.

Bijvoorbeeld: sudo sed -i s@/usr/share/keyrings/@/etc/apt/keyrings@ /etc/apt/sources.list.d/winehq-focal.sources

  • Op 19 december 2018 is de verificatiesleutel van de WineHQ server gewijzigd

Mocht de sleutel voor die tijd zijn gebruikt, dan moet deze opnieuw worden toegevoegd. Gebruik sudo apt update om de veranderingen door te voeren.

  • Apt-key is verouderd

Vroeger werd apt-key gebruikt om de Wine sleutel toe te voegen. Mocht hierover een melding komen, verwijder de sleutel met: sudo apt-key del "D43F 6401 4536 9C51 D786 DDEA 76F1 A20F F987 672F" Verwijder hierna ook de regel van het WineHQ-archief uit /etc/apt/sources.list(.d/).

Mirror sync in progress?

Als er een foutmelding komt bij het installeren van een WineHQ pakket met de regel Mirror sync in progress? dan is dat waarschijnlijk ook het probleem. Er zijn namelijk heel veel pakketten die gesynchroniseerd moeten worden, wat lang kan duren.

Wacht een paar uur en probeer het nog een keer. Als het probleem meer dan een dag duurt, maak dan een foutrapport aan.

Mijn {{{1}}} versie staat er niet tussen

Wanneer een versie van {{{1}}} niet meer ondersteund wordt, worden er geen nieuwe Wine pakketten meer voor gemaakt. Je kan op de WineHQ server kijken of er oudere pakketten beschikbaar zijn. Het toevoegen van de WineHQ server is niet nodig. Er worden namelijk geen nieuwe versies meer gemaakt. Het downloaden en installeren van de vier WineHQ deb-pakketten is voldoende.

Let op: deze pakketten worden niet meer bijgewerkt en worden niet meer ondersteund.

Notities

  • Er worden geen items in het menu gemaakt voor winecfg en andere ingebouwde programma's van Wine. Na het bijwerken van Wine van {{{1}}}, zullen deze weggehaald worden. Deze kunnen met een menu editor zelf gemaakt worden.
  • Wine wordt geïnstalleerd in /opt/wine-<soort>/
  • Er zijn geen pakketten voor wine-mono en wine-gecko. Deze worden automatisch gedownload en geïnstalleerd als Wine voor de eerste keer wordt gestart of als er een nieuwe wineprefix wordt gemaakt. Als dit niet lukt, lees dan de wiki pagina's van Gecko of Mono.
  • Vanaf Wine 5.7 kunnen de WineHQ pakketten ingesteld worden met debconf om gebruik te maken van CAP_NET_RAW. Veel programma's hebben dit niet nodig en is om veiligheidsredenen uitgeschakeld. Als dit wel nodig is (omdat bijvoorbeeld het programma het ping commando nodig heeft) voer dan de volgende opdracht uit en beantwoord de drie vragen met "ja": dpkg-reconfigure wine-<soort>-amd64 wine-<soort> wine-<soort>-i386
  • Er wordt geen Binfmt_misc registratie uitgevoerd. Lees de documentatie van {{{1}}} om dit handmatig te doen (man update-binfmts).
  • Een volledige Wine installatie op een 64-bit systeem bestaat uit vier pakketten.
winehq-<soort> Dit pakket zorgt er onder andere voor dat het wine commando systeembreed beschikbaar is.
wine-<soort> Dit pakket heeft de volgende twee pakketten als afhankelijkheid en zorgt voor een werkende installatie.
wine-<soort>-amd64 Het 64-bit gedeelte van Wine.
wine-<soort>-i386 Het 32-bit gedeelte van Wine.
Door Wine over verschillende pakketten te verdelen, is het mogelijk om verschillende soorten naast elkaar te installeren.
Bijvoorbeeld: Gebruik Wine-stable als standaard versie en installeer Wine-staging om sommige programma's te testen.
Installeer Wine-stable met:
sudo apt install --install-recommends winehq-stable
Installeer Wine-staging met:
sudo apt install --install-recommends wine-staging (Let op: er staat geen hq na wine)
Voer een programma uit met Wine-stable:
wine program.exe
Voer een ander programma uit met Wine-staging:
WINEPREFIX=~/wine-staging /opt/wine-staging/bin/wine program.exe
(Het wordt aanbevolen om elke Wine-soort zijn eigen wineprefix te geven.)
  • Er staan meerdere versies van Wine op de repository. Standaard wordt de laatste versie geïnstalleerd. Gewoonlijk wordt de nieuwste versie aanbevolen, maar het kan voorkomen dat een oudere versie gewenst is. Gebruik apt policy winehq-<soort> om de beschikbare versies te tonen.
Een oudere versie kan geïnstalleerd worden met: sudo apt install winehq-<soort>=<version>.
Bijvoorbeeld:
sudo apt install winehq-staging=7.12~bookworm-1
Als de Wine pakketten moeten worden afgewaardeerd, dan moeten alle vier de pakketten gegeven worden:
sudo apt install winehq-staging=7.12~bookworm-1 wine-staging=7.12~bookworm-1 wine-staging-amd64=7.12~bookworm-1 wine-staging-i386=7.12~bookworm-1

Een installatie zonder internet

Om Wine op een {{{1}}} computer zonder internetverbinding te kunnen installeren is een tweede {{{1}}} computer (of VM) met een internetverbinding nodig. Deze kan de benodigde deb-pakketten downloaden.

Voeg op de computer met de internetverbinding de WineHQ repository toe. Haal daarna de pakketten binnen zonder deze te installeren:

sudo apt-get clean

sudo apt-get --download-only install winehq-<soort>

sudo apt-get --download-only dist-upgrade

Kopieër alle deb-bestanden van /var/cache/apt/archives naar een USB stick:

cp -R /var/cache/apt/archives/ /media/usb-drive/deb-pkgs/

Nu kunnen de deb-pakketen geïnstalleerd worden op de computer zonder internetverbinding

cd /media/usb-drive/deb-pkgs sudo dpkg -i *.deb

Wine zelf compileren

  • Vanaf versie 4.0-rc2, heeft de WineHQ repository ook de .dsc, .diff.gz, en .orig.tar.gz bestanden. Deze bronbestanden kunnen hier gevonden worden "https://dl.winehq.org/wine-builds/{{{2}}}/dists/<versie>/main/source"
  • De nieuwste versies van {{{1}}} is multiarch. Het is mogelijk om alle benodigde 64 en 32-bit pakketten naast elkaar te installeren. Hierdoor kan Wine gebouwd worden door de instructies te volgen die staan op de WineHQ wiki.
  • Oudere versies van {{{1}}} zijn waarschijnlijk niet multiarch. Het lukt niet om de 32 en 64-bit bibliotheken naast elkaar te installeren. Op een 64-bit systeem moet dan een aparte omgeving gemaakt worden om het 32-bit gedeelte te maken. Op de WineHQ wiki staan instructies hoe dit kan in een chroot of een container.

Lees ook