Difference between revisions of "Debian zhcn"

From WineHQ Wiki
Jump to: navigation, search
(Add libfaudio0 package warning.)
(Add libfaudio0 package warning.)
 
Line 5: Line 5:
 
{{warning}} '''WineHQ 源仓库的密钥于 2018-12-19 改变过。如果您在此之前下载添加过该密钥,您需要重新下载和添加新的密钥并运行 sudo apt update 以获得更新。'''  
 
{{warning}} '''WineHQ 源仓库的密钥于 2018-12-19 改变过。如果您在此之前下载添加过该密钥,您需要重新下载和添加新的密钥并运行 sudo apt update 以获得更新。'''  
  
{{warning}}'''从 Wine 4.5 开始,用于 Debian testing 的 wine-devel 包增加对 libfaudio0 的依赖。由于发行版尚未提供该包,您可以从 OBS 下载 libfaudio0 安装包。详情请看:https://forum.winehq.org/viewtopic.php?f=8&t=32192 for details。'''
+
{{warning}}'''从 Wine 4.5 开始,用于 Debian testing 的 wine-devel 包增加对 libfaudio0 的依赖。由于发行版尚未提供该包,您可以从 OBS 下载 libfaudio0 安装包。详情请看:https://forum.winehq.org/viewtopic.php?f=8&t=32192 '''
  
 
{{info}} '''''Raspbian 用户:''' WineHQ 提供的安装包只能用于 x86 架构;它们不能被安装于 ARM 架构系统。''
 
{{info}} '''''Raspbian 用户:''' WineHQ 提供的安装包只能用于 x86 架构;它们不能被安装于 ARM 架构系统。''

Latest revision as of 21:32, 12 July 2019


其他语言: Flag of the United Kingdom.svg English

安装 WineHQ 安装包

Dialog-warning.svg WineHQ 源仓库的密钥于 2018-12-19 改变过。如果您在此之前下载添加过该密钥,您需要重新下载和添加新的密钥并运行 sudo apt update 以获得更新。

Dialog-warning.svg从 Wine 4.5 开始,用于 Debian testing 的 wine-devel 包增加对 libfaudio0 的依赖。由于发行版尚未提供该包,您可以从 OBS 下载 libfaudio0 安装包。详情请看:https://forum.winehq.org/viewtopic.php?f=8&t=32192

Tango-style info icon.svg Raspbian 用户: WineHQ 提供的安装包只能用于 x86 架构;它们不能被安装于 ARM 架构系统。

首先,开启 32 位支持:

sudo dpkg --add-architecture i386

然后安装被用于签发安装包的密钥:

wget -nc https://dl.winehq.org/wine-builds/Release.key
sudo apt-key add Release.key

然后添加软件源到 /etc/apt/sources.list 或创建一个 *.list 文件于 /etc/apt/sources.list.d/,并包含以下内容:

Debian 版本 向 /etc/apt/sources.list 填入:
Debian 8 (Jessie) deb https://dl.winehq.org/wine-builds/debian/ jessie main
Debian 9 (Stretch) deb https://dl.winehq.org/wine-builds/debian/ stretch main
Debian 10 (目前的 Testing) (Buster) deb https://dl.winehq.org/wine-builds/debian/ buster main

更新软件仓库:

sudo apt update

然后安装 以下其中一个安装包

稳定分支
sudo apt install --install-recommends winehq-stable
开发分支
sudo apt install --install-recommends winehq-devel
Staging 分支
sudo apt install --install-recommends winehq-staging

如果 apt 提示缺少依赖,请先安装缺少的依赖,然后重复以上两步(update 和 install)。


如果您之前使用过来自发行版自己打包的安装包,您会发现它们和 WineHQ 提供的有以下不同:

  • 文件被安装在 /opt/wine-devel 或 /opt/wine-staging。
  • 没有为 Wine 的内置程序(winecfg 等等)创建菜单项,并且如果您是从发行版自己打包的安装包升级上来的,原来的菜单项也会被删除。您可以使用菜单编辑器自己再次创建。
  • 没有添加 Binfmt_misc 注册项。如果您想手动添加,请查看您使用的发行版关于 update-binfmts 的文档。
  • WineHQ 当前没有提供 wine-gecko 和 wine-moon 的安装包。所以当创建新的 wine 配置目录时,您将会被询问是否下载这些组建。为了得到更好的兼容性,我们建议您选择“安装”。如果下载过程发生出错,请查看 GeckoMono 的 wiki 页面来进行手动安装。

构建源码包

从 4.0-rc2 开始,WineHQ 的源仓库已经包含了由 OBS 生成的 .dsc、.diff.gz 和 .orig.tar.gz 等文件。这些源码包可以在 /main/source 下以您的发行版版本( 例如: jessie、stretch 或 buster )命名的子目录找到。

编译 WoW64

Debian 的 Multiarch 支持目前尚不完整,所以目前您无法简单地同时安装 32 位和 64 位库。如果您使用的不是 64 位系统,您将会需要创建一个独立的环境来安装和构建 32 位依赖。 请查看 构建 Wine 来了解如何在 chroot 或容器中构建 Wine。

相关文档