Here is a list of libraries needed by Wine and the packages in popular Linux distros that provide them.

Required Libraries

Library

Component

Opensuse 10.3

Fedora 9

Mandriva 2008.1

ld-linux.so.2

glibc

glibc

glibc

libICE.so.6

xorg-x11-libICE

libICE

libice6

libSM.so.6

xorg-x11-libSM

libSM

libsm6

libX11.so.6

xorg-x11-libX11

libX11

libx11_6

libXau.so.6

xorg-x11-libXau

libXau

libxau6

libXext.so.6

xorg-x11-libXext

libXext

libxext6

libXt.so.6

xorg-x11-libXt

libXt

libxt6

libXxf86vm.so.1

xorg-x11-libs

libXxf86vm

libxxf86vm1

libc.so.6

glibc

glibc

glibc

libdl.so.2

glibc

glibc

glibc

libfreetype.so.6

gdi32, wineps

freetype2

freetype

libfreetype6

libm.so.6

glibc

glibc

glibc

libpthread.so.0

glibc

glibc

glibc

Optional Libraries

Library

Component

Opensuse 10.3

Fedora 9

Mandriva 2008.1

libGL.so.1

opengl32

mesa

mesa-libGL

libmesagl1

libasound.so.2

winealsa, wineesd

libasound2

alsa-lib

libalsa2

libaudio.so.2

winenas

alsa-lib

libnas2

libaudiofile.so.0

wineesd

audiofile

audiofile

libaudiofile0

libcrypt.so.1

wldap32

glibc

glibc

glibc

libcups.so.2

wineps, winspool

cups-lib

cups-libs

libcups2

libesd.so.0

winesd

esound

esound-libs

libesound0

libexif.so.12

gphoto2.ds

libexif

libexif

libexif12

libgcrypt.so.11

wldap32

libgcrypt

libgcrypt

libgcrypt11

libgpg-error.so.0

wldap32

libgpg-error

libgpg-error

libgpg-error0

libgphoto2.so.2

gphoto2.ds

libgphoto2

gphoto2

libgphoto2

liblber.so.2

wldap32

libldap_r.so.2

wldap32

libnsl.so.1

wldap32

glibc

glibc

glibc

libsane.so.1

sane.ds

sane-backends

sane-backends-libs

libsane1-1

libsasl2.so.2

wldap32

cyrus-sasl

cyrus-sasl-lib

libsasl2

libtasn1.so.2

wldap32

libxml2.so.2

msxml3

libxml2

libxml2

libxml2

libxslt.so.1

msxml3

libxslt

libxslt

libxslt1

LibraryDependencies (last edited 2008-06-18 17:41:48 by LeiZhang)